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Information in this manual is subject to change without notice. This manual (“Manual” or 

“Documentation”) and the software (“Software”) described in it are copyrighted, with all rights 

reserved. By using this Manual and accompanying Software, you, the end user, agree to the 

terms set forth in the License Agreement. 

 

Copyright 

Under the copyright laws, this Manual or the Software may not be copied, in whole or in 

part, without the express consent of CheckMark Inc. (“CheckMark Software”), except in the 

normal use of the Software or to make a backup copy of the Software for your own use. The 

same proprietary and copyright notices must be affixed to any permitted copies as were affixed 

to the original. This exception does not allow copies to be made for others, whether or not sold, 

but all of the material purchased (with all backup copies) may be sold or given to another 

person. Under the law, copying includes translating into another language or format. 

 

Federal copyright law prohibits you from copying the written materials accompanying the 

Software without first obtaining our permission. You may not alter, modify or adapt the 

Software or Documentation. In addition, you may not translate, decompile, disassemble or 

reverse engineer the Software. You also may not create any derivative works based on this 

Software or Documentation. A derivative work is defined as a translation or other form in which 

the Software may be recast, transformed or adapted. 

 

Limited Warranty on Media and Replacement 

EVEN THOUGH CHECKMARK INC. HAS TESTED THE SOFTWARE AND REVIEWED THE 

DOCUMENTATION, CHECKMARK INC. MAKES NO WARRANTY OR REPRESENTATION, EITHER 

EXPRESS OR IMPLIED, WITH RE-SPECT TO THE SOFTWARE, ITS QUALITY, PERFORMANCE, 

MERCHANTABILITY, OR FITNESS FOR A PARTIC-ULAR PURPOSE. AS A RESULT, THIS 

SOFTWARE IS SOLD “AS IS”, AND YOU THE PURCHASER ARE ASSUMING THE ENTIRE RISK AS 

TO ITS QUALITY AND PERFORMANCE. IN NO EVENT WILL CHECKMARK INC. BE LIABLE FOR 

DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES RESULTING FROM 

ANY DEFECT IN THE SOFTWARE OR ITS DOCUMENTATION, EVEN IF ADVISED OF THE 

POSSIBILITY OF SUCH DAMAGES. 

 

The Warranty and remedies set forth above are exclusive and in lieu of all others, oral or 

written, express or implied. No CheckMark Inc. dealer, agent, Consultant, or employee is 

authorized to make any modification, extension, or addition to this warranty. 

 

Some states do not allow the exclusion or limitation of implied warranties or liability for 

incidental or consequential damages, so the above limitation or exclusion may not apply to you. 

This warranty gives you specific legal rights, and you may also have other rights which vary 

from state to state. 

 

Trademarks 

CheckMark Inc. and MultiLedger are registered trademarks of CheckMark Inc. All other 

references are trademarks of their respective owners. © 2024 CheckMark Inc. pdf rev 11/24. 
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Chapter 1 Getting Started 

CheckMark 1095 helps centralize all your 1095 (Affordable Care Act) filing needs. With this 

program you can print or even e-file all forms needed for filing 1094-B, 1095-B, 1094- C and 1095-C. 

The program will print the forms on a blank sheet of paper. 

Before starting the set up of your employer and employees, please read through this manual. It 

covers general setup and 1095 requirements, as well as how you can receive additional support 

directly from Checkmark, Inc. 

System Requirements  

CheckMark 1095 can be installed on a computer running either Macintosh or Windows 

operating systems. This software is a single-user application and not designed for multi- user access 

of the data files. DO NOT install the application program on a server. Install the program locally on 

the user’s hard drive even if you save the data on a server. 

Users will need to have a computer running an operating system of either Windows 8 or higher 

including Windows 10 & 11, or Macintosh OS X 10.6 or higher including Sierra, Mojave, Catalina, Big 

Sur, Monterey, & Ventura. 

Along with a compatible printer, the latest version of Adobe Reader is also required to properly 

print the forms from the program. You can download a free copy of Adobe Reader from Adobe’s 

website at www.Adobe.com. 

Whichever operating system you choose, a working knowledge of the operating system is 

essential. For more information about the basics and navigation of your operating system, see the 

user manual that came with your computer. 
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Software and Patch Updates  

Each year the program is issued with the latest 1095 Forms as well as added features. Program 

patches are released as needed throughout the year for the current version of the software. Patches 

are available online at www.checkmark.com. Renewal notices are sent out each year, in the fall, 

announcing the next update. Updates must be purchased each year to receive support and the 

ability to install patches for changes. 
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How to Purchase and Download CheckMark 1095 

Software 

1. Sign in to My Account using your credentials and go to the 2025 Updates Portal. 

My Account Link: https://www.checkmark.com/account/sign-in 

2. Choose the software you want to purchase. By default, one employer and one computer 

will be included as part of the base license. 

 

https://www.checkmark.com/account/sign-in
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(a) Add the number of companies you want to manage with your software.  

(b) Add the number of computers you wish to install the software on. 

(c) Select version E-File or Print. 

(d) Select the platform. 

(e) Make sure the Cloud Backup Add-On is selected to protect your data with secure 

backups, giving you peace of mind and easy access to your information anytime, 

anywhere. 

(f) Always select the Pro+ Update to enjoy priority support and faster response times, 

ensuring your issues are resolved quickly and your workflow stays uninterrupted. 

3. Click Add to Cart and then scroll down to the bottom of the page and click Next to proceed. 

4. Remember to stock up on checks, business, and tax forms for your business. Simply add the 

necessary items to your cart and click Next to complete your order. 

5. Review the items in your cart, confirm your billing address, enter your payment details, and 

complete your purchase. 

6. Once the payment is successful, you will be taken to the Product Details page. 

Here you will find the  

(a) Download links 

(b) License Key – This is a 16-character alphanumeric code. Keep it secure and do not 

share it with anyone to protect your software access. 

(c) View Details – This screen provides additional insights into your license usage, 

including the number of computers your software is installed on and the number of 

companies you have added. 
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7. Click to download the purchased software based on your operating system directly to your 

local computer. 

How to Get More Help  

This manual covers general set up and reporting. There may be items that are specific to your 

employer that are not addressed here except in general terms. For these times, CheckMark, Inc. 

offers additional support. 

Only registered users can receive technical support so please, take a moment and read the 

License Agreement, fill out the Registration Card and send it in. 

Support is offered via internet submission, E-mail, fax or telephone. Whenever you contact 

support, have your customer number OR product registration number available. It is important that 

you are at your computer with CheckMark 1095 running when speaking with support to best resolve 

your question/problem. 
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Support Plans  

CheckMark Software offers several additional support plans to meet your needs: 

Priority Support 

300 minutes with your annual subscription, with an 800 phone number exclusively for priority 

support customers and top of the queue assistance. Phone, email or fax support. 

Professional Support 

90 minutes with your annual subscription. Phone, email or fax support. 

Before Contacting Support/Other Resources  

Check for Latest 

Version 

Users with internet access can make sure that they are up-to-date as often 

as they wish by selecting Check for Updates under the Help menu in the 

program. If necessary, download and install the latest update (may require 

purchase if not using the current year’s version). 

1095 Manual Users can access the 1095 program manual from the Help menu while in the 

CheckMark 1095 program. An updated manual is included with each 

update. 

Online Knowledge 

Base 

Users with internet access can check the online data base for answers to 

common questions. Access to the Knowledge Base can be obtained by going 

to the Help menu and selecting CheckMark Knowledge Base. You can also 

access the Knowledge Base directly from the CheckMark website at 

https://kb.checkmark.com. 

Online Tutorials These short videos are valuable for new users and seasoned pros alike. Each 

topic is easy to understand as you are taken step-by-step through features 

and procedures. You can access the tutorials under the Help menu in the 

program or by going to the CheckMark website at https://checkmark.com/. 

 

 

 

https://kb.checkmark.com/
https://checkmark.com/
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Contact CheckMark  

For questions regarding the 1095 software, you can choose one of the following methods to 

request technical support: Online at: https://www.checkmark.com/. 

Sign in to My Account using your credentials. Click on SUPPORT and Select Add Ticket. Fill in all 

the necessary fields and click Submit to create a support ticket. 

Once your ticket is submitted, you will receive a notification on your registered email address. 

Our support team will now take care of your query and update you on the ticket. You can view your 

submitted tickets in SUPPORT > Ticket History in My Account. 

Our program continues to improve with the input of our users. If you wish to see a feature 

considered for possible implementation into the Payroll program, please send us your suggestions 

Sales – 800-444-9922 or sales@checkmark.com 

Support – 970-225-0387 or support@checkmark.com 

Customer Service – 970-225-0522 or info@checkmark.com 

Fax – 970-225-0611 

Address – CheckMark Inc, 323 W Drake Rd, Ste. 100, Fort Collins, CO 80526 

 

  

https://www.checkmark.com/
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Chapter 2 Installation, Activation and 

Basic Use 
If you need to install the software on multiple computers, additional licenses are required for 

each computer. All installations, activations, and software use require an internet connection—no 

more CDs. 

Installing and Activating 1095 software 

1. Open the folder containing the installation file for the software update, and double-click the 

file to start the installation process. Ensure your computer is connected to the internet 

during installation for a smooth setup. 

2. After the CheckMark Software is successfully installed on your computer, a software 

activation screen will appear. Enter your Customer ID, Registered Email Address, and License 

Key, and then click Submit to initiate the activation process. (Please enter the license key in 

uppercase). 

Note: The Customer ID can be found on the Account Info page, and the License Key can be 

located on the Product Details page. 
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3. If all the details are entered correctly, a web page will then open in your browser to validate 

your license information. The process will take a few seconds. Make sure your internet 

connection is stable during validation, and do not close or refresh the page. 

 

4. Once your license information is validated, a success message will appear, and you can close 

the tab. 

 

5. The OK button will now be enabled on the software activation screen. Click OK. 

6. An important screen appears. Read the instructions, and then click Continue. 
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Congratulations! Your license is now activated, and your software is ready for use. 
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How to Install Software on Additional Computers 

1. Sign in to My Account, click PRODUCTS in the menu, and go to Product Details. Click the OS 

version for which you want to download the software installer. 

2. Run the downloaded installer and follow the on-screen instructions to complete the 

installation. 

3. After installation, a software activation screen will appear. Enter your Customer ID, 

Registered Email Address, and License Key used on your original computer, then click 

Submit.  

Note: After entering the license key, press ENTER to enable the Submit button. 

4. An alert message will notify you that the maximum device limit has been reached for your 

license, click OK to proceed. 

      

5. After the device limit popup is closed, the Purchase License button on the activation popup 

will now be enabled. Click on the Purchase License button. This will automatically log you 

into your CheckMark account and take you to the web page to buy additional computer 

licenses. 
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6. Select the number of additional licenses needed, each costing $99, and click PROCEED to 

complete your payment. After the successful payment, close the webpage and return to the 

Software Activation screen, where the OK button should be enabled. Click OK to finish the 

activation process.  

Congratulations! Your license is now activated, and your software is ready for use. 

Note: To access your previous companies' data from another computer, ensure that you have 

copied the employer's database file from the old computer to the new one where CheckMark 

Software is installed. Use the Restore Database option from the Tools menu to restore previously 

backed-up employer data. Alternatively, use the Database Manager option from the File menu to 

fetch employer databases. 

Important: 

 You can only run the companies that have been paid for under your current license. 

 You will only be able to open the companies that were created on the previous computer. 

 To add new companies to a newly licensed computer, you must purchase additional 

employer licenses. If you have already purchased the licenses, you can proceed to add the 

companies to the new computer. 
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How to Remove Computers from the License 

1. Sign in to My Account, click 'PRODUCTS' in the menu, and go to the 'Product Details' page. 

2. Click on the View Details button for the software from which you wish to remove the 

associated computer installation. 

 

3. The License Information page will open. Locate the computer you want to remove from the 

license and click "Remove." If you are unsure of the serial key for the computer, click the link 

"How to Locate Your Serial Number" and follow the steps to find your computer's serial 

number. 
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4. A pop-up window will appear asking for confirmation. Click the Confirm button to proceed. 

 

Note: This action cannot be undone. Once the computer is removed, the license will be free 

for installation on another device. 

5. After confirming, you will receive an email at your registered email address, confirming that 

the computer has been removed from the license. 

Caution: If you removed the computer either intentionally or by mistake, you will need to 

reinstall the software on the same or a new computer. You will need your license key, 

registered email address, and customer ID to activate the software. Be sure to back up all 

your employer's data before reinstalling to prevent data loss. 
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Opening CheckMark 1095: New User 

1. Open the CheckMark 1095 application. You can use either the shortcut or alias that was 

created or go to the CheckMark 1095 folder that was installed and double-click the 

CheckMark 1095 application file. 

2. The first time you open the program the welcome screen appears. This screen provides 

useful information regarding the set up of Security, Customizing screens and fonts and 

accessing the Manual. 

Click the Print Message button to print out this information. 

    

 

Important: It is recommended that you set up a password to protect your private information. 

For information on setting up passwords, see Setting up Users and Passwords. 
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Opening CheckMark 1095: Upgrading Old Files 

The information will be stored in a database that is created the first time you open your previous 

files, the default location is: 

Macintosh: HD\Documents\CheckMark\1095\(year)  

Windows: C:\Documents\CheckMark\1095\(year) 

1. Open the CheckMark 1095 application. You can either use the shortcut or alias that was 

created or go to the CheckMark 1095 folder that was installed and double-click the 

CheckMark 1095 application file. 

2. If you have a previous 1095 database from a prior year, the program will ask you if you 

want to import the Employer and Employee information. 

3. Click Yes to continue. Enter the Username and Password from the prior year, if requested. 

 

4. A pop up window asks if you want to clear out the prior amounts. Click Yes to zero out 

amounts and continue or No to retain the prior year’s amount information 

5. If you clicked Yes, you’ll be notified once the data is successfully imported. 
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Starting a New Year (Import Prior Year) 

1. After activating the license, click Import Prior Year from the File menu. 

 

2. The Start New Year (Import from Prior Year) screen will appear, allowing you to start 

importing data. 
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3. Now select the companies you want to import from your database. 

Use Add Database to List and Find Databases to search your computer for existing 

databases. You can only import companies from one database at a time. If you have multiple 

databases, repeat the process for each. 

Important Update (2025 onwards): Starting with the 2025 update, each database can store 

only one employer. In previous versions, multiple companies could be stored in a single 

database. Plan accordingly when managing databases. 
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4. After selecting the employer you want to import, click the Start New Year button.  

Note: You can import up to 100 companies at a time. If you have more than 100 companies, 

kindly split your list and import them in batches. 

5. A confirmation popup will appear, click OK to continue. 
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6. You will be taken to a web page for validation. The system will check how many companies 

you've purchased versus how many you're trying to import. If you are importing the correct 

number of companies (equal to or less than the number you purchased), the import will 

proceed smoothly. 

           

If you exceed your purchase limit: An alert popup appears. 

            

For example, if you purchased licenses for 1 employer but tried to import 3, you will be 

directed to the purchase page where you can buy an additional license for the extra 

employer.             

7. After the successful addition of the employer to your license, close the webpage. Return to 

the application and click the Start New Year button on the "Start New Year (Import from 

Prior Year)" screen.  

A confirmation popup will appear. 
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If the employer shown is correct, click Yes to proceed. 

If it’s incorrect, click No and select another employer from your database. 

8. After confirmation, a final popup will inform you that the employer has been successfully 

imported.  
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9. To start using the imported employer, click on Open Database or Database Manager from 

the File menu. Select the employer you just imported and then click Open to access it. 

Congratulations! Your prior year's employer has been successfully imported and is now 

ready for your 1095 reporting process. You can now proceed with reporting 1095 taxes for 

the current year based on the imported data. 
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Using the Database Manager 

CheckMark 1095 stores employer data in a database.  

Important Update (2025 onwards): Starting with the 2025 update, each database can store only 

one employer. In previous versions, multiple companies could be stored in a single database. Plan 

accordingly when managing databases. 

Choose Database Manager from the File menu. 

       

Storing Employer Files in Separate Databases 

Starting in 2025, each employer must be stored in its own individual database. This change 

ensures that each employer's data is kept separate and managed independently. When performing 

actions such as backing up, restoring, closing, or advancing to a new year, these operations will now 

be applied to each employer's database individually. 
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Create New Database 

This option allows you to create and save a new database in any location you wish. Keep in mind 

that each database can store multiple companies. 

1. Click New Employer from the File menu. 

2. Enter a Database Name. Click the Choose Directory button to select a new location to save 

the database. 

 

3. Click Create Database to save the new database. 

4. Enter employer name and then click OK. 

 

Important Update (2025 onwards): In previous versions, multiple companies could be 

stored in a single database. Starting with the 2025 Update, each database can store only one 

employer. 
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Add Database to List 

This button allows you to add an already- existing database to the list. For example, if you copied 

over a database from another computer and the Database Manager does not list this database, you 

can choose Add Database to List and browse to that location to update the Database Manager’s list. 

1. Click on Add Database to List. 

An Open dialog box appears. 

 

2. Browse to the location where the database is saved. 

3. Select the database and click Open. 

The database is added to the list in the Database Manager. 
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Rename Database 

This option allows you to rename the database. It is recommended you use only alpha-numeric 

characters. 

1. Click Rename Database. 

The following alert appears: 

                

2. Click Yes. Otherwise, if you don’t want to rename at this time, click NO.         

3. Enter the new name and click OK to save. 

The Rename Database window appears:  
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Open Database 

This option allows you to choose a different database and open it up to view all saved 1095 

companies in that particular database. 

Select the database you want to open and press Open Database. 

The new database is now open and all companies stored in this database are available under the 

Open Employer command under the File menu. 

Close Database Manager 

This option closes the Database Manager window. 

Update Employer 

This command allows you to update the currently selected employer’s information. Once the 

program is launched, open the database that contains the employer you want to update. Highlight 

the employer and click the Update Employer on the command center. Enter the information you 

want to change, and then click Update Employer to save the changes. 

Note: Apart from the employer's name, you can modify all other employer information. 

Exiting CheckMark 1095 

To exit or quit CheckMark 1095: 

 Choose Exit from the File menu (Windows) 

 Choose Quit from the CheckMark 1095 menu (Mac) 
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Chapter 3 Creating a New Employer 

This chapter shows you how to create a new employer and enter basic employer information. 

Creating a New Employer 

1. On Windows, double click the 1095 shortcut on the desktop or click the Start menu, select 

Programs, then select CheckMark 1095 from the CheckMark Inc. File. 

On Macintosh, double click on the CheckMark 1095 alias on the dock or on your Desktop, or 

double click the CheckMark 1095 icon located in the install folder that was installed on your 

hard drive. 

2. Choose New Employer from the File menu. 

A "Create Database" screen will appear. 

 

3. Enter a name for the new database and click the Create Database button. 

4. When the New Employer screen appears, enter your Employer Name. 

Warning: Ensure the employer name is correct, as it cannot be changed once saved. 
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5. Click OK. 

6. You will be taken to the webpage for employer validation. Once the validation is complete, 

close the webpage, and the employer will be added to the employer list. 

 

Important: Every time a new employer is added, it will be validated by taking you to a 

webpage. If you have already purchased the employer, it will confirm that the employer has 

been added successfully. If the employer has not yet been purchased, you will be taken to 

the webpage for purchase. An alert message will prompt you to validate the employer if it is 

not registered in our database; click OK to proceed. 
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Updating an Existing Employer 

1. Highlight the employer in the list you wish to update and click the Update Employer button. 

2. After all changes have been made to the Employer Information, click the Update Employer 

button to save the changes. 

How to Add Additional Companies 

1. Open your CheckMark Software. Navigate to the File menu and click New Employer. 

 A "Create Database" screen will appear. 

 

2. Enter a name for the new database and click the Create Database button. 

3. When the New Employer screen appears, enter your Employer Name. 

Warning: Ensure the employer name is correct, as it cannot be changed once saved. 
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4. Click OK after entering the details. 

5. You will be taken to the webpage for employer validation. Once the validation is complete, 

close the webpage, and the employer will be added to the employer list. 

              
6. If you do not have a license to add additional companies, an alert will appear when the 

employer limit is reached. 

               
7. Click OK, and you'll be taken to a webpage to purchase additional employer licenses. 
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8. On the webpage, select the number of additional companies needed, each costing $30, and 

then click PROCEED. Review your order on the order information page, confirm the details 

are correct, and click Checkout. On the payment page, enter credit card details and click 

Pay to complete the transaction. 

9. After the payment is successful, go back to CheckMark Software the employer will be 

added to the employer list. 

Important: Every time a new employer is added, it will be validated by taking you to a 

webpage. If you have already purchased the employer, it will confirm that the employer has 

been added successfully. If the employer has not yet been purchased, you will be taken to 

the webpage for purchase. An alert message will prompt you to validate the employer if it 

is not registered in our database; click OK to proceed. 
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Chapter 4 Set Up 

Setting up Users and Passwords 

IMPORTANT: Although not required, it is recommended you set up a password to protect your 

private information. 

1. Click on the Tools menu in the upper left hand corner of the screen and select Admin. 

                    

2. To create a new user, click the Add User button. 
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3. Enter the Name and Password. 

Note: The Name and Password are case sensitive. 

4.  Click the checkbox for This user should be granted ADMIN privileges if you want this 

user to be able to add, update or delete other users. 

IMPORTANT: The first user set up will have Admin privileges. You cannot delete or 

change this user’s ADMIN privileges until another user with Admin privileges is created. 

Users with ADMIN privileges can add/delete/update other users, Backup and Restore 

the database and Check for updates. 

       

5. Click the Add User button to save. 

Updating Users 

1. Click on the Tools menu in the upper left hand corner of the screen and select Admin. 

2. Highlight the user you want to update from the list. 

3. Click the Update User button. 

4. Make the necessary changes and click the Update User button to save. 
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Deleting Users 

1. Click on the Tools menu in the upper left hand corner of the screen and select Admin. 

2. Highlight the user you want to delete from the list. 

3. Click the Delete User button. 

4. In the popup window, verify that the correct user name is selected and click the Confirm 

Delete button. 

 

Note: If you delete all users, the software will not prompt for a password upon launching the 

program. 
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Setting Screen Font Size 

This setting allows you to customize how big or small you want the font on the screen in the 

program. There are five settings to choose from: Smallest Font, Small Font, Medium Font, Large 

Font, And Largest Font. 

Selecting Font Size 

1. Click on the Font Sizes menu at the top of the screen. 

2. Select which font you want to use. You can choose any font at anytime from the main 

screen window. 
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Adjusting Screen Size 

You can adjust the size of each screen to maximize or minimize your viewing area. 

To increase or decrease the size of any screen, simply click and hold the mouse button on the 

lower right hand corner of any screen and drag the corner to the desired position. 
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Chapter 5 Setting up Employees 

This chapter explains how to setup new Employees for each employer. 

Creating New Employee 

1. Open the Database that contains the employer to which you want to add employee. If no 

Database exists you must first create one. See Create New Database. 

2. Select an Employer from the list. If no Employers are listed, you must first set up an 

employer before adding employees. For information on setting up a new employer, see 

Creating a New . 

3. Click the New Employee button. 

                  

The list of fields for the new employee corresponds to the same fields found on the 1095 forms 

4. Choose which type of 1095 form this employee should receive and click OK. 
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5. Enter the employee’s SSN along with the Employee’s Information. Do not enter the Date 

of Birth unless the SSN is not available. 

6. Fill in any fields that are applicable for the employee. 

7. Click the Add Employee button to save the information. 

If any information is invalid, a popup window will open explaining which fields have errors. 

             

Press Cancel to go back to the set up screen to correct any errors, or Continue Anyway to 

save the employee information. 
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NOTE: If any field has an invalid entry, once you return to the Employee set up screen, that 

field name will show up in “Red”. In addition, some fields will not save the invalid 

information and remain empty. For more information on validated information, see 

“Validated Status” on page 50. 

Updating an Existing Employee 

1. Select the employer that contains the employee(s) you wish to update. 

2. Highlight the employee in the list you wish to update and click Update Employee button. 

3. After all changes have been made to the Employee Information, click Update Employee 

button to save changes. 

Voided Employee 

If a 1095 is incorrectly filed, or included in a filing, that was incorrectly filed, you can resubmit 

the 1095 as a voided copy to void the original 1095 to the IRS. Please read the IRS Instructions on 

how to file this. 

1. Select the employee from the list and click Update Employee button 

2. Click the Void check box at the top of the screen. 

3. Mark the corresponding checkbox next to “NOT Printed’ and/or “NOT Complete” if you 

want to change the status and click the Save and Continue button. If you do not want to 

change the status, click the Cancel button. If you do not select either checkbox, you can still 

click the Save and Continue button to save any updated employee information without 

changing their status. 

If you initially printed the form, reprint another 1095 with the updated Void status and 

submit that form to the IRS with a new 1094 form for instructions on printing 1095 forms, 

see Printing 1095s for Employees. 
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If you initially e-filed, create a new .txt file with that employee and updated Void 

information and submit it to the IRS. For information on e-Filing, see  

Creating a file to e-File. 

Corrected Employee 

If a 1095 is filed, or included in a filing, with incorrect information, a Corrected 1095 must be 

filed with the IRS. 

1. Select the employee from the list and click the Update Employee button. 

2. Click the Corrected check box at the top of the screen, update any information and click the 

Update Employee button to save. 

3. Mark the corresponding checkbox next to “NOT Printed’ and/or “NOT Complete” if you 

want to change the status and click the Save and Continue button. If you do not want to 

change the status, click the Cancel button. If you do not select either checkbox, you can still 

click the Save and Continue button to save any updated employee information without 

changing their status. 

If you initially printed the form, reprint another 1095 with the updated Corrected status 

and submit that form to the IRS with a new 1094. For instructions on printing 1095 forms, 

see Printing 1095s for Employees. 

If you initially e-Filed, create a new .txt file with that employee and updated Corrected 

information and submit it to the IRS. For information on e-Filing, see  

Creating a file to e-File. 
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Deleting a Employee 

1. Select the employer that contains the employee(s) you wish to delete 

2. Highlight the employee in the list you wish to delete. 

If you want to delete more than one employee, you can highlight multiple employees at 

once. See Selecting Multiple Employees. 

3. Click Delete Employee button. 

4. A pop-up window appears to confirm that these are the employees you want to delete. 

 

5. Click Confirm Delete to complete the process. 
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Filtering Employees 

You can use the Filter button to search for certain employees in the list. To find a particular 

employee, enter all or part of the name into the Filter box area above the employees section and 

click the Filter button. The Filter will search for any employees that contain those variables. 

You can also use an asterisk (*) to help sort groups. For instance, if you enter the first letter and 

then an asterisk, ex: N*, you will receive all employees that start with the letter “N”. 

Sort Employees 

You can sort employees by Ascending or Descending order. To select which type of sort to use, 

go under the Sort menu at the top of the screen and choose either Sort Employees Ascending or 

Sort Employees Descending. 
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Status 

The Status drop down menu has certain statuses that are categorized based upon their setup 

and completion of being printed. You can sort using the different options to see which employees or 

vendors have been Printed, Completed, Validated, Voided, or Corrected. 

Employees can be in multiple statuses at the same time; however you can only sort by one 

status at a time. 
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Printed Status 

You can easily sort using this status to see which employees still need the form 1095 printed. 

You can select either Printed or Not Printed status to sort for employees by whether or not you 

have printed a 1095 for them. Once you select the Print Forms for Employee command from the File 

menu, that employee will automatically be moved to the Printed status from the NOT Printed 

status. 

Completed Status 

You can use the Completed status to indicate which employees have or have not been printed or 

e-Filed this form 1095 for employer related copies. 

Once you select the Print forms for Filing option under the File menu, employees listed under 

NOT Completed will be moved to the Completed status. 

Validated Status 

Sorting by Validated or NOT Validated helps you easily determine if there is any employee that 

is not set up correctly. In the employee screen, certain fields require specific characters, numbers, 

etc. to be accepted upon filing. 

Select Validated to see which employees are ready to be filed. Select NOT Validated to see any 

employees that have set up criteria which is incorrect for filing purposes. Once you have sorted by 

NOT Validated, select a employee and click on the Update Employee button to view the set up and 

make necessary changes. Fields marked in “RED” do not meet the requirements for filing and 

corrections should be made. 
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Voided Status 

In the Employee set up screen, there is a checkbox at the top of the screen for Void.  If you filed 

a 1095 for an employee that was unintended, you can mark Void to resent the 1095 for that 

employee as a void status. 

Choosing a Voided status will list all employees marked Void in the Employee set up screen. All 

other employees that are not marked Void in the employee set up screen are listed as NOT Voided 

for a status. 

Corrected Status 

In the Employee set up screen, there is a checkbox at the top of the screen for Corrected. If you 

filed an incorrect 1095 and need to resubmit a new 1095 with updated information, select the 

Corrected checkbox in the employees set up screen before submitting the new 1095 information.  

The Corrected status indicates all employees who are marked as Corrected in the employee set 

up screen. All other employees will be listed as Not Corrected. 
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Selecting Multiple Employees 

Consecutive Selection 

Windows: You can select multiple employees by clicking the first employee while holding down 

the mouse and moving the mouse down through the list 

You can also click the first employee, hold down the ‘SHIFT’ key on the keyboard and then click 

on the last employee you want in the list. 

Macintosh: Click on the first employee you want in the list, hold down the ‘SHIFT’ key on the 

keyboard and then click on the last employee you want in the list. 
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Non-Consecutive Selection 

Windows: To select specific employees as a group, click on the first employee you want, hold 

down the ‘CTRL’ key on the keyboard and click on any other employees you want to include. 

Macintosh: To select specific employees as a group, click on the first employee you want, hold 

down the ‘COMMAND’ key on the keyboard (also known as the Apple key) and click any other 

employees you want to include. 
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Chapter 6 Exporting and Importing 

This chapter explains how to export employees and companies from CheckMark Payroll as well 

as companies from CheckMark MultiLedger and how to import this information from CheckMark 

Payroll, MultiLedger or tab-delimited text file. 

Exporting Company Information from CheckMark 

Payroll 

1. Open up CheckMark Payroll, under File menu and choose Export Company. 

 

2. A save dialogue box appears. In the File name field, give the file a name if needed and 

choose a location to save the file to, an example would be your desktop. 

3. Click Save. 
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Exporting Company Information from MultiLedger 

1. Open the MultiLedger; under the File menu select Export Company… 

2. A save dialogue box appears. In the File name field, give the file a name if needed and 

choose a location to save the file to, an example would be your desktop. 

3. Click Save. 

Exporting Employees from CheckMark Payroll 

1. Open CheckMark Payroll, under File menu and choose Export Employees. 

2. Select the fields that you want to export from the list. 

Note: If the employees to be imported are using different types of 1095 forms, you should 

create an export file for each type of form. For Example, one export file for 1095-B and one 

file for 1095-C. 

3.  Click the Export 1095 button. The Selected Field list will automatically populate with the 

correct available fields to import into the 1095 software. 

 

4. A save dialogue box appears in the File name field, give the file a name if needed and 

choose a location to save the file to, an example would be your Desktop. Click Save. 
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Importing Employer information from CheckMark 

Payroll or MultiLedger 

1. Open the CheckMark 1095 application. 

2. Open the Database which contains the employer you want to import into. 

Note: If the database that you want to import employees to does not exist, you will need to 

create a new database before importing. For information on creating a new employer or 

importing a employer, see Creating a New . 

3. Under the File menu select Import Employer. 

 

4. Choose the type employer you are importing and then click OK. 
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5. Click the Import from Payroll or MultiLedger button. The appropriate fields will 

automatically populate for you. 

 

6. A dialogue box appears allowing you to browse to the location where you saved your text 

file from CheckMark Payroll or MultiLedger. 

7. Select the text file and click Open. The employer will be imported into the selected 

database. 
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Importing a Employees from CheckMark Payroll and 

MultiLedger 

1. Open the CheckMark 1095 application. 

2. Open the Database which contains the employer you want to import into. 

3. Select 1094-B or 1094-C depending on which type you will be importing. 

4. Select the employer you want to import employees for. 

Note: If the employer you want to import employees to does not exist, you will need to 

create a new employer or import an employer before importing employees. For 

information on creating a new employer or importing an employer, see Creating a New 

Employer. 

5. Under the File menu select Import Employee. 

 

6. Select Import Employee in the popup window. 
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7. Click the Import from Payroll or MultiLedger button. The appropriate fields will 

automatically populate for you. 

 

8. A dialogue box appears allowing you to browse to the location where you saved your text 

file from CheckMark Payroll or MultiLedger. 

9. Select the text file and click Open. All employees will be imported into the selected 

employer. 

Importing using a tab-delimited text file 

1. Open up the CheckMark 1095 application. 

2. Open the Database which contains the employer you want to import into. 

Note: If the employer you want to import employees to does not exist, you will need to 

create a new employer or import a employer before importing employees. For information 

on creating a new employer or importing a employer, see Creating a New  or “Importing a 

Employer”. 

3. Go under the File menu and select Import Employee or Import Employer. 
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4. Select Employee or Employer in the popup window. 

5. If you choose Import Employer, in the popup window select which type of 1095 employer 

you are importing: 1094-B or 1094-C. 
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6. The import screen allows you to select which fields are being imported. Select the fields in 

the same order as the text file you’re importing. Click the Import button after you have 

added all fields to the Selected Field list. 

 

7. An Open Dialogue box appears allowing you to browse to the location where you saved 

your text file. 

8. Select the text file and click Open. 
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Text File Format for Importing 

CheckMark 1095 program uses a tab-delimited .txt file for importing Companies and the 

Employees. 

Each field is separated by a Tab with Return at the end of the record before starting the next 

employee. An example of a text file to be imported is shown below and contains the Selected Fields: 

Employer Name/Last Name (required), First Name, Address 1, Address 2, City, State, Zip, Employees 

ID. 

Power[tab]Max[tab]44 Main St[tab]Ste 101[tab]Fort Collins[tab]CO[tab]80525[tab]123- 45-

6789[return] 

 If any fields are not applicable, for instance the address 2 field, a space can be used as a 

place holder. For example:  

Power[tab]Max[tab]44 Main ST[tab]”space”[tab]Fort Collins[tab]CO[tab]80525[tab]123- 45-

6789[return] 

 If no space is included, two consecutive [tabs] will also work. For example: 

Power[tab]Max[tab]44 Main St[tab][tab]FortCollins[tab]CO[tab]80525[tab]123-45- 6789[return] 

IMPORTANT: Make sure the items in the Selected Fields list are in the same order as the items 

in the text file being imported to ensure that all values are imported into the correct fields. 
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Chapter 7 Printing 1094 & 1095 Forms 
This chapter explains how to print 1095 forms for the employer and each employee and the 

1094 form you will submit to IRS. 

While CheckMark Inc. attempts to maintain up-to-date and accurate tax and form information, 

we cannot be responsible for changes or discrepancies in tax values and forms that are filed 

incorrectly. 

IMPORTANT: You must install the latest version of Adobe Reader to print 1094 and 1095 forms 

properly. Go to www.adobe.com to download the latest update. 

Print 1094 Forms and 1095 Form for Each Employer 

1. Select which type of 1094 form you want to print from the drop down menu: 1094-B or 

1094-C. 

2. Select the employer you wish to print 1094 and 1095 forms. 

3. Select which employee(s) in the list you would like to print forms for. If no employees are 

selected, all employees will be included. 

Note: You can sort the employees by using the Status drop down menu to group employees 

by Printed, Completed, Validated, Corrected, and Void. For more information on using the 

Status drop down menu and what each Status means, see Status. 

4. Under the File menu, select the Print Forms for Employer option. 



 
 

CheckMark 1095 Software User Manual  Page 64 of 75 

               

This will bring up the print dialog. You can print to PDF to verify the information before printing 

the forms or just print the forms. The 1094-B is the Transmittal of Health Coverage Information 

Returns. This gets sent with the IRS copies of the 1095-B forms for each employee. 
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Printing 1095s for Employees 

1. Select which type of 1094 form you want to print from the drop down menu: 1094-B or 

1094-C. 

2. Select the employer you wish to print 1094 and 1095 forms. 

3. Select which employee(s) in the list you would like to print forms for. If no employ- ees are 

selected, all employees will be included. 

Note: You can sort the employees by Status drop down menu to group employees as 

Printed, Completed, Validated, Corrected and Void. For more information on using the 

Status drop down menu and what each Status means, see Status. 

4. Under the File menu, select the Print Forms for Employee option. 

 

Note: If a security warning appears click allow for the form to open in Adobe Acrobat. 

5. This will bring up the print dialog. You can print to PDF to verify the information before 

printing the forms or just print the forms. 
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Chapter 8 e-File 
This chapter shows you how to e-File 1095 forms using the IRS ACA Information Returns (AIR) 

Program. If you have never e-Filed 1095s in the past, you will need to visit the IRS website at 

www.irs.gov to sign up for an AIR system account and receive a Transmitter Control Code (TCC), you 

should do this 45-60 days before the filing deadline. 

While CheckMark Inc. attempts to maintain up-to-date and accurate form information, we 

cannot be held responsible for changes or discrepancies in forms that are filed incorrectly. 

Note: The ability to e-File is only available to customers who have purchased the 1095 e-File 

version. If you need to upgrade from the printed version, call 1-800-444-9922 or visit the CheckMark 

website at www.checkmark.com. 

Creating a file to e-File 

Before creating your first live -e-file to be submitted you must complete a communication test. 

1. Select the employer you want to e-File for. 

2. Select the employees you wish to include. You can sort using the different forms or choose 

All Forms from the drop down menu to select all employees. For information on selecting 

multiple employees, see Selecting Multiple Employees. 

Note: If you do not choose any employees, the e-File option will not be available. 

You can sort the employees by the Status drop down menu to group employees as Printed, 

Completed, Validated, Corrected and Void. For more information on using the Status drop 

down menu and what Status means see Status. 

3. From the File menu, choose E File. 
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4. If there are any issues with the forms a popup screen will appear stating where the errors 

are. 

 

5. Click Cancel to go back and correct there errors. If you feel this box is incorrect then click 

Continue Anyway to continue with creating your e-file. 
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6. In the pop-up window. Fill in all applicable fields. 

If the address is outside the United States, check the 'Address not in US territory' checkbox, 

which will allow you to enter details in a text box below the state drop-down. Selecting this 

checkbox will automatically disable the state drop-down. 

 

7. Optional: If you need more information on how to set up an E-file account, click the How to 

E-file button. A pop-up window with important links on how to first apply, create an AIR 

system account. 

 

8. Once all the information is filled in, click the Create E-File Now button.  
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9. If there are any errors in the transmitter information window, you will see a pop-up 

window explaining what errors occurred. 

                

10. Click Cancel to go back to the transmitter information window to correct any set up errors. 

Or click Continue Anyway to proceed with saving the .txt file. 

11. A save as dialog box opens. You will save 2 files. One is a manifest file and the other is a 

form file.

 

12. Use the default name. Save the file to a location that is easy to find. The Desktop is an easy 

location to save the file to and find it there later when you are ready to submit the file to 

the IRS AIR system. Click Save. 
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Note: Keep both files together in same location so the manifest file is with its 

corresponding form file to prevent errors. 

Corrected/Replacement Transmission 

1. After making corrections (if doing the corrected transmission), you need to mark those 

sections you fixed as corrected. If the fix was for an employee, please make sure you check 

the Corrected box at the top of the screen when you update the Employee. If you are a C 

company, you also need to go to the Update Employer section on the 1094-C and select the 

corrected box. B companies do not have this option under the Update Employer option, so 

B companies can ignore the employer step, but make sure to check the Corrected box in 

the Update Employee screen. Marking corrected can be ignored for replacement 

transmissions, however in the E- file window there is a specific check box that needs to be 

selected toward the bottom of the screen to indicate what type of Transmission is 

happening your options are Replacement Transmission, Replacement Submission, and Test 

File. 
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2. When you originally submitted your 1095 you would have been sent a Receipt ID 

confirmation from the IRS. You will need to have the Receipt ID when creating the 

"Corrected e-file/Replacement Transmission". 

3. Go to the File menu and select E-file like you normally would. However, when the pop up 

window opens for you to enter all the transmitter information you will see at the bottom of 

this page, a field for "Original Receipt Id", enter this for the corrected/ replacement form 

submission. You need to enter the "Original Receipt Id" that you received after submitting 

the original files. 

 

4. Save the E-Files and resubmit. 
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Chapter 9 Backup and Restore 
Making backups is critical to protecting your data. You should always keep current backups. 

CheckMark 1095 allows you to easily backup your data to any external source for safekeeping. 

Backing Up Using the Backup Database Command 

Using the Backup Database command within the program allows you to backup a duplicate copy 

of the database. You can restore this database in case of computer failure or to revert back to a 

previous database in case of an error in your current database. It is recommended that you make 

current backup databases anytime you modify information. 

Note: Only users with Admin privileges can backup and restore a database. For more 

information on setting up Admin privileges, see Setting up Users and Passwords. 

1. Click on the Tools menu in the upper left hand corner of the screen and select Backup 

Database. 
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2. A Save In dialog box appears. Choose a destination you would like to save the backup 

database to. 

3. A default name of backup (with the current date).db is given. Change the name of the 

backup if you wish and leave the .db extension. 

 

4. Click Save. 
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Restoring Database using Restore Database Command 

In case of computer failure, corruption or if you made a mistake and would like to revert back to 

a previous database, the Restore Database command will open any previous backups you have 

saved. You must have a Database created before you can restore a backup. 

1. Click on the Tools menu in the upper left hand corner of the screen and select Restore 

Database. 

    

2. A dialogue box opens. Browse to the location of the Backup Database file. 
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3. Select the file and click Open. 

Important: Restoring a database file will overwrite the existing .db file. Restoring a 

database file is used in cases of the current file becoming damaged or information being 

entered incorrectly into the current database. Restoring from a previous database is faster 

than manually updating the incorrect information. 


